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Creating a Catalog 

Kudo creates catalogs by searching your disks for image files, creating thumbnails and 
entering the relevant information.    

To create a Kudo catalog:

1. Select    New from the Kudo File menu
2. Enter a name for the catalog in the File Name box. (Kudo will add the ".kdb" filename 

extension).    
3. Click OK and Kudo will display your new empty catalog.

(Shortcut = Ctrl+N)



Opening a Catalog

To open an image catalog:
1. Select Open from the Kudo File menu. The Open dialog appears.

2. In the File Name text box, type the path/filename of the catalog you want to open 
or choose the filename using standard Windows selection methods.    Click OK. 
The selected catalog window opens, displaying its thumbnails.    Scroll bars will 
appear if additional thumbnails cannot be displayed within the window at its 
present size.

To open several catalogs, repeat the above steps for each catalog you want to open. Each 
catalog you open will appear in its own window. Use the Window menu selections to Tile or 
Cascade multiple open catalog windows.
 
Clicking in a catalog window makes that window active; any menu commands or actions you 
perform affect only the active window.

(Shortcut = Ctrl+O)



Display Original

Kudo maintains a link between the thumbnail image in the catalog and the original file.    While 
in Kudo use the Display Original option to preview the original image file in a full-sized window. 

1. Select the thumbnail you wish to preview.
2. Choose Display Original from the Image menu.
3. Kudo will find the original image file and display it in a full-sized window. 

To preview other image files, simply click their thumbnails while the Display Original
window is open.    

Note:    Kudo can not display original files stored on removable media (i.e. floppy disks, 
removable cartridges, etc.) if the device is not present in your system, Kudo will ask 
you to insert the correct disk. 

(Shortcut = Ctrl+E)



Drag and Drop Images from Kudo

There are three methods for taking an image from a Kudo catalog and placing it into a 
document:

Drag and Drop.
Copy and Paste.
You can also, of course, note the file name and location and use it to insert the image from within 

the target application.

Kudo takes advantage of Windows technology (DDE and OLE 2.0) which allows you to Drag 
and Drop images onto all popular graphics applications.    When you Drag and Drop from your 
Kudo to an open document, Kudo will find the original image file and place it in the selected 
desktop publishing document or other page layout application, with pinpoint accuracy.

To Drag and Drop a thumbnail to an open document: 
1. Select the thumbnail.
2. Hold down the mouse button and drag it to the open document.

Note:    Pinpoint accuracy requires an OLE 2.0 client application or a special Kudo Place 
Module.    Place Modules are included for MS Word, PageMaker, QuarkXPress, and Word 
Perfect.

Note: The Place Module for the application you are using must be installed in the Kudo    
directory.    The format of the file being placed must be supported by that application.    The 
cursor will indicate a plus (+) or a document symbol (q) if the target application supports the file
being placed and the "not cursor (¦) if the target application does not.

Note:  For Microsoft Word users, Word will indicate that you can drop the image only when the
cursor is over the Word application tool bar or the status bar (along the bottom of the window). 
When the image is dropped, it will be inserted at the exact location of the Word "I-beam" 
(insertion point).    Release the mouse button and Kudo will find the image file and place it into 
the document. 



Sorting

When you open a catalog, Kudo lists the thumbnails according to when they were added to the
catalog.    Use the Sort menu to list the thumbnails by name, file size, kind, modification date, 
location or date.    For example, sort by "Modification Date" to see which image files have been
recently updated or sort by "Kind" to group images by file type.    You can sort the catalog using
the same criteria found in the Find feature.

Sort and Find use the same criteria but they affect the catalog differently.    With Find you use 
the criteria to determine which thumbnails Kudo should display and which it should hide from 
view.    With Sort you re-arrange the thumbnails that are displayed.

When you close and re-open the catalog, Kudo shows all the thumbnails in their original order.

To sort your catalog:
1. Select sorting criteria from the Sort menu.
2. Kudo will automatically re-arrange the thumbnails and display them in their new 

order.



Printing Your Catalog

Use the standard Printer Setup and Print commands to print part or all of your catalog.    The 
Print feature always prints the current selection of thumbnails.    For example, to print all 
thumbnails in a catalog, use 

 All    to find "everything" (the default), and then select print from the File menu.

To print thumbnails with file name and size only, select Gallery View prior to printing your 
catalog.    Printing a catalog in small Gallery View prints the maximum number of thumbnails 
per page. To print thumbnails with complete information, including file location, select List View
and then print the catalog.    Printing a catalog in List View provides more text information on 
images but prints fewer thumbnails on each page.

(Shortcut = Ctrl+P)



Other Menu Options

Kudo uses several other menu options that are standard Windows commands.    Use these 
commands as you would use them in other applications.    They include:

Edit menu commands:
Undo Text Reverses the last action performed.    For example, if you Cut text, then 

select Undo Text before pasting, it will reappear at its original location in 
the note field (text only).

Delete Thumbnail Marks selected thumbnails for deletion from the catalog.    The thumbnails
are deleted when the catalog is closed.

Undelete Thumbnail Reverses the action of the    Cut and Delete Thumbnail commands, that 
is, it unmarks thumbnails previously selected for deletion from the 
catalog.    The Undelete Thumbnail command can only be used prior to 
closing the catalog. 

File menu commands:
Close Closes the selected catalog.
Exit Ends your Kudo session.



Notes Boxes

Click on the List View button.    This view displays the notes that you have associated with your
thumbnails. The List View is the only place in the Image Browser where you can edit the notes.

With Kudo, you can edit these notes on-the-fly.    Add, delete or change text by selecting a 
notes field to edit, and then simply keying in your notes.    Use standard Windows text editing 
commands to edit your notes. 



Saving Your Catalog

With Kudo's automatic save feature, you know that your catalog is always up-to-date.    Kudo 
automatically saves the catalog every time you use it.    So if you change the notes, update the 
catalog, or make other changes, Kudo saves them for you when    you close the catalog.



How an Update Affects a Catalog

Kudo will update your catalog in three ways:
1. When image files are added.    Any new file on the disk will be added as a new catalog 

entry.    Suppose your disk had 20 image files on it when you first created the catalog 
"KUDO1.kdb".    Now the disk has 25 image files on it.    When you update "KUDO1.kdb", 
Kudo will add the five new image files to the catalog.

2. When you change the entered information.    If you change the file "Sailboat," Kudo will 
change the thumbnail and its information during an update.    In this case, Kudo only 
corrects the images contents and the file size.    The update preserves your notes.

3. When a previously cataloged image file is moved or rename, Kudo will treat it as a new 
file.    The original thumbnail will remains in the catalog until deleted.



Adding a Single File to the Catalog

The easiest way to add a single file to a catalog is using Drag & Drop.    From the right hand 
side of File Manager, select the file you wish to add to your catalog.    Drag the file from File 
Manager and Drop onto Kudo.    Kudo will render a Thumbnail and update the currently 
selected catalog.

Another way to add a single thumbnail is to select Add/Update from the File Menu,    enter the 
path and filename of the image in the File Name Box of the Scan window and then click OK. 



Moving and Copying Thumbnails between Catalogs

With several catalogs, you may find that you need to transfer thumbnails from one catalog to 
another.    There are two ways to transfer thumbnails between catalogs:

Copy Thumbnail, Paste Thumbnail or Drag and Drop.    Copy and Paste adds a thumbnail to the 
target catalog.

Cut Thumbnail and Paste Thumbnail.    Cut and Paste marks the thumbnail for deletion from the 
first catalog and additon to the second when the catalog is closed.



Using Copy and Paste

You will be able to drag and drop images to all leading graphics applications.    They all support
Windows Drop-onto, and for pinpoint accuracy, many even offer OLE 2.0 (client) support.    For 
other applications and older Windows 2.x applications that do not have these capabilities, you 
can still place an image using copy and paste.

To use Copy and Paste:
1. Select the thumbnail image.
2. Choose "Copy Thumbnail" under the Edit menu.
3. Kudo will find the original image file and copy it to the clipboard.
4. Open the target document.
5. Choose "Paste" under the Edit menu of the target document.
6. Your target application will paste the image onto the document page.

Note:    When you use copy, the entire original image file is placed on the clipboard.    Be 
sure you have enough RAM to support this action.



Contacting Technical Support

FAX:
Questions can be faxed 24 hours a day, 7 days a week.    Fax your questions to 
619-272-4292.    You will receive an answer to your fax within 24 business hours.

WEB SITE:
Imspace has opened a Web site for your conveniece. Here, you can drop off e-mail, or 
download sample catalogs. Our address is www.imspace.com.



Adding or Updating a Catalog

To add or update image thumbnails:
1. Click on the File-Add/Update menu
2. Enter the drive and directory to scan.    
3. Then press OK to begin the cataloging process.

When this operation has completed, the Kudo catalog window will display the thumbnails in 
your catalog window. The catalog will also include the name, location, size and file extension 
for each image.

The size of the window and thumbnail view option determines the number of thumbnails that 
Kudo displays at a time.    You can resize the window to change the number of thumbnails 
displayed. Scroll bars will appear on your catalog window if additional thumbnails are 
available.



File Menu

New 
Open 
Add/Update 
Close 
Print 
Print Setup 
Exit 



Edit Menu

Undo text 
Cut Text 
Copy Text 
Paste Text 
Clear Text 
Delete Text 

Cut Thumbnail 
Copy Thumbnail 
Paste Thumbnail 
Delete Thumbnail 
Undelete Thumbnail 



View Menu

Gallery View 
List View 
Small Gallery View 



Image Menu

Display Original  
Get Info 
Find 
Find All 
 



Sort Menu

Name - Sorts thumbnails by their eight character file name
    Size - Sorts thumbnails by the size of the actual image size
    Kind - Sorts thumbnails by their image type (extension)
    Date - Sorts thumbnails by the date the image file was Last Modified
Location - Sorts thumbnails by the image file's location pathname
Notes - Sorts thumbnails by the first word in the Notes Box



Window Menu

                Cascade - Displays open catalogs in standard Windows Cascade view
      Tile - Displays open catalogs in standard Windows Tile view

Arrange Icons - Organizes all iconized catalogs in the Kudo window
              Close All - Closes all open catalogs and returns to Kudo window



Close

The Close command closes the active catalog.

(Shortcut = Ctrl+W)



Print Setup

Print Setup, as in most Windows applications, gives options to select available printers and 
change their options.

(Shortcut = Ctrl+P)



Exit

The Exit command closes all open catalogs and then closes Kudo.

(Shortcut = Alt+F4)



Undo text

Undo Text reverses the last action performed.    For example, if you enter text, Delete text, or 
Cut text, then select Undo Text before pasting, it will reappear at its original location in the 
Notes Box (text only).



Get Info

Get Info gives you quick access to a thumbnail's information.    This option tells you the file 
name, volume, size, modification date, location and any notes you have attached to the 
thumbnail.

To display a thumbnail's information:
1. Select a thumbnail.
2. Select "Image-Get Info"
3. Kudo will display the information in a floating window. 

You can also display the Info Window using the Info Button.    When the Info window is open, 
click other thumbnails to display their information.    

(Shortcut = Ctrl+I)



Find

You can choose the Find Option using either the Image menu or Find button icon. Use the Find
feature to search the catalog for thumbnails with specific characteristics.    Kudo searches the 
catalog and displays the thumbnails that were identified in the search.    All other thumbnails 
are hidden from view.

For example, if you search the catalog's notes for a client name, Kudo only displays the 
thumbnails with that information.    Kudo does not delete or edit the remaining thumbnails; it 
just hides them from view.    To return to the full catalog, use Find to search the catalog for 
"Everything" or select "Find-All" from the "Image" pull-down menu. 

When you select the Find feature, Kudo displays the Find Image dialog box.    
Use the first combo box to tell Kudo the thumbnail characteristic it should search.    You can 

search by name, size, date modified, notes or location.

Use the next combo box menu to tell Kudo how to search the catalog.    The selections in this 
combo box become available after you make a selection in the first combo box. Use the options contains, 
starts with or ends with in lieu of the wild card characters * or ?.

Use the edit text box to tell Kudo what words or information to search for.

For example, you may have a catalog that includes a series of aircraft clip art images.    You 
can use the Find button to search the catalog for any thumbnail records whose notes contain 
the word "Plane".    To return to the full catalog, use Find and choose "Everything" or select 
Find-All from the Image pull-down menu. 

(Shortcut = Ctrl+F)



Find All

Find All searches for and displays all thumbnails in the active catalog.    This feature is also 
used to restore all thumbnails after a Find operation.    Find All is equivalent to exectuing a Find
"Everything" using the Find Button.

(Shortcut = Ctrl+A)
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Drag and Drop Compatibility

Drag and Drop can be used from the Kudo onto the following applications:

All graphics applications that support Drag and Drop (OLE 2.0) from the File 
Manager/Windows Explorer.    This includes virtually all leading applications.

All graphics, desktop publishing, and multimedia applications that support Drag and Drop 
provide pinpoint accuracy when dropping onto a page layout.
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Troubleshooting

Out of Memory thumbnail received when examining folders or disks to create or update 
a catalog or when displaying original thumbnails.    Kudo requires more memory when 
creating a catalog or displaying an original than is required for search and browse operations.   
The actual amount required depends on the size and type of image files you are cataloging.    
While 4 MB of memory is sufficient for most operations, it may be necessary to make more 
memory available to Kudo.

To make more memory available to Kudo:
Quit the other applications that you have running under Windows.    If this does not 
correct the problem, contact Imspace Systems Technical Support. 

Files in certain formats do not appear as thumbnails in Kudo catalogs.
Kudo uses translators listed in the KUDO.INI file in your Kudo directory.    The translators are 
based on the Aldus Filter industry standard.    Each line in the "ini" describes the extension of 
the file and the filter that should process that file.

Clicking the Stop button when making or updating a catalog does nothing.
Kudo only checks the status of the Stop button between the creation of individual thumbnails.   
If the image file Kudo is cataloging is large and complex, it requires more time to create the 
thumbnail.    Clicking the stop button during the creation of such a thumbnail may not be 
noticed by Kudo until Kudo is finished creating the current thumbnail.

Nothing happens when you drag a thumbnail into a PageMaker or QuarkXPress 
document.    Applications such as PageMaker and QuarkXPress only support the importing of 
specific file formats.    If a file format is not supported by the application you are using, nothing 
will happen when you drag the Kudo thumbnail into the application document.    Consult the 
documentation provided with the application to determine which file formats are supported, or 
copy and paste the thumbnail from Kudo.



 Un-install Kudo

To un-install Kudo, please click on the uninstaller file in the Kudo directory.



Why Use Kudo?

You have hundreds of clip art, logos and other graphic image files on your computer, all 
created using different applications.    Unfortunately, to look through your images, you must find
and open each file. 

With Kudo, you can:
Zoom through the catalog to locate the image file's thumbnail.
Reference the image file's location, size and format.
Use Display Original to view the full-sized image in a floating window.
Place the image into another document.

Kudo saves you hours of time.    You've been there . . .

You want to find a graphic file so you search, open a file, close it, search, open another file, 
close it...    and on and on.    That's the old way to find an image.

As a graphic design professional, you have hundreds, or even thousands, of images created 
for projects or collected from commercial clip art sources.    You may subscribe to services that 
provide images monthly, stored by the hundreds, on CDs.

You have a photograph or piece of artwork in mind that would fit perfectly in your new layout.    
The question is:    "Where did I see that image?".    While you have seen it a hundred times, 
can you find it now?    Would    it be faster to re-create the image or use another that you can 
find that is "close enough"?    Kudo is a time-saving tool designed to allow more opportunity for 
originality and design because less time is spent searching for images.

You need the image of a sunset for your current project.    Kudo presents you with thumbnails 
of all your image files.    Now you can see exactly what the image in each file looks like.    Using
the Riffle Control, you quickly zoom through the catalog until you see the one you want.    The 
search has become as simple as riffling the pages of a photograph album.

Once you find an image that will work, you display an original with a simple menu selection.    
When you are satisfied with the selection, you simply Drag and Drop the image directly into 
your favorite graphics or desktop publishing application.

Selecting artwork from a catalog has become a visual search.    With Kudo, you quickly 
browse, display original and select graphics and multimedia files.    Your attention can now be 
focused on content and creative tasks, rather than wasting time locating the right image file.



Find Button

Use the Find button to search the catalog for thumbnails with specific characteristics.    Kudo 
searches the catalog and displays the thumbnails that were identified in the search.    All other 
thumbnails are hidden from view.

For example, if you search the catalog's notes for a client name, Kudo only displays the 
thumbnails with that information.    Kudo does not delete or edit the remaining thumbnails; it 
just hides them from view.    To return to the full catalog, use Find to search the catalog for 
"Everything" or select "Find-All" from the "Image" pull-down menu. 

When you select the Find feature, Kudo displays the Find Image dialog box.    
Use the first combo box to tell Kudo the thumbnail characteristic it should search.    You can 

search by name, size, date modified, notes or location.

Use the next combo box menu to tell Kudo how to search the catalog.    The selections in this 
combo box will become available after you make a selection in the first combo box.

Use the edit text box to tell Kudo what words or information to search for.    Wild card characters 
such as "*" or "?" are not necessary.

You can also choose the Find option using the Image menu.    For example, you may have a 
catalog that includes a series of aircraft clip art images.    You can use the Find button to 
search the catalog for any thumbnail records whose notes contain the word "Plane".    To return
to the full catalog, use Find and choose "Everything" or select Find-All from the Image pull-
down menu. 



Info Button

The Info button gives you quick access to a thumbnail's information.    This option tells you the 
file kind, volume, size and any notes you have attached to the thumbnail.

To display a thumbnail's information:
1. Select a thumbnail.
2. Click the Info button.
3. Kudo will display the information in a floating window. 

You can also choose Get Info using the "Image" pull down menu.    When the Info 
window is open, click other thumbnails to display their information. 



Scroll Bars

Use the Scroll bar to move forward and backward through the catalog.    

Remember that Kudo will display the catalog based on the current Find criteria.    If you have 
selected "Everything" in the Find feature, the entire catalog is available.    However, if you have
used Find to select a specific group of files, you can only scroll through those files.    You must 
set new search criteria to scroll through your other thumbnails.



How to Update a Catalog

To update a Catalog:
1. Select -"Open" from the File menu and type the path/filename of the catalog to 

update or choose the filename using standard Windows selection methods. 
2. Select -"Add/Update" from the File menu.
3. The Add Update dialog box prompts you to select a drive:\directory to the image 

files you wish to catalog. Kudo catalogs your disks, adding, deleting and updating 
thumbnails, as necessary. 

Kudo will search the disk for image files and change the catalog entries as needed.    As it 
searches the disk, it displays a progress dialog.

See also:
How an Update Affects a Catalog 



Thumbnail View Buttons

The Gallery View and List View buttons allow you to switch among the three views.    You move
among the views by clicking the view button you prefer.

The Gallery View uses a grid style layout showing several thumbnails,    the file 
name, type    and size.    Click the Info button to view detail about the selected 
thumbnail.

The Small Gallery View uses a grid style layout like Gallery View. The 
thumbnails however are much smaller and do not have the file name, type or size,
therefore allowing the user to see many more thumbnails at one time.

The List View uses a vertical layout with fewer thumbnails in the window, but with
more information about each file.    The list view shows the thumbnails in a vertical
column and the file information in a second vertical column.
 

Note:    The list view also shows your notes or description of the thumbnail.    With Kudo,
you can edit these notes on-the-fly.    Add, delete or change text by simply keying in 
your notes.    Use standard Windows text editing commands to edit your notes. 



Gallery View

The Gallery View uses a grid style layout showing several thumbnails, their file type and file 
size at once.    Click the Info button to view detail about the selected thumbnail.

The Gallery View, Small Gallery View and List View  buttons allow you to toggle between 
views.    Switch among the views by clicking a different view button.

(Shortcut = Ctrl+G)



List View

Unlike Gallery View,and Small Gallery View List View uses a vertical layout with fewer 
thumbnails in the window, but with more information about each file.    The list view shows the 
thumbnails in a vertical column and the file information in a second vertical column.
 
The list view also shows your notes or descriptions of the thumbnails.    With Kudo, you can 
edit these notes by clicking on the notes area and typing the additions, deletions or changes to
the text.    Use standard Windows text editing commands to edit your notes. 

(Shortcut = Ctrl+L)



Small Gallery View

The Small Gallery View uses the same layout as Gallery, but with much smaller images and no
image imformation thus allowing the user to view more images at one time.    Click the Info 
button to view details about the selected thumbnail.

(Shortcut = Ctrl+S)



Help Menu

The Help menu displays the Help File, Using Help, Open Kudo Web Page, Open Catalogs 
Web Page and the Kudo "About" Window.



Status Bar

The Status Bar is found in the lower left corner. It displays the number of thumbnails currently 
displayable out of the total thumbnails contained in the active catalog.    

For example, the active catalog contains 100 thumbnails.    After executing the    Find feature, 
only 35 thumbnails met the search criteria.    The catalog window will only display the 35 found 
thumbnails and the Status Bar will display "35 of 100".

To restore the catalog to the full 100 displayable thumbnails, use either the Find All option from
the "Image Menu" or find "Everything" using the Find Button 



Title Bar

A window's Title Bar displays the name of the open application or the path/filename of the 
catalog or both application name and path/filename of catalog.



Maximize & Minimize Window

The Maximize (horizontal bar on top) and the Minimize (horizontal bar on bottom) buttons are 
standard Windows options.    

Maximize enlarges the current window size to full screen. 
Minimize reduces the current window to an icon on the status bar.    

To display the window, click on the icon.



Thumbnail Information

In List View, the thumbnail's information section displays the notes you have attached to the 
thumbnail.

For more information, you can display the Info Window using the Info Button.    When the Info 
window is open, click other thumbnails to display their information. 



Cut Text

Cut Text copies text to the clipboard and deletes the text from the selected thumbnail's Notes 
Box. 



Cut Thumbnail

Cut Thumbnail copies the selected thumbnail to the clipboard and marks the a selected 
thumbnail for deletion.

(Shortcut = Ctrl+X)

See also:
Moving and Copying Thumbnails between Catalogs 
Undelete Thumbnail 



Copy Text

Copy Text copies text to the clipboard from the selected thumbnail's Notes Box. Text on the 
clipboard can be pasted into another Notes Box.



Copy Thumbnail

Copy Thumbnail copies a thumbnail to the clipboard from a selected catalog.

(Shortcut = Ctrl+C)

See also:
Moving and Copying Thumbnails between Catalogs 



Clear Text

Clear Text deletes all text from the selected thumbnail's and can not be undone. Notes.

See also:
Undo text 



Delete Text

Delete Text deletes highlighted text from the selected thumbnail's  Notes.

See also:
Undo text 



Delete Thumbnail

Delete Thumbnail marks selected thumbnails for deletion from the catalog.    The thumbnails 
are deleted when the catalog is closed.

Use Undelete Thumbnail    to unmark thumbnails.



Paste Text

Paste Text copies text from the clipboard into the selected thumbnail's Notes Box. 



Undelete Thumbnail

Undelete Thumbnail reverses the action of the Delete Thumbnail command, that is, it unmarks 
thumbnails previously selected for deletion from the catalog.    The Undelete Thumbnail 
command can only be used prior to closing the catalog. 



Paste Thumbnail
Paste Thumbnail copies a thumbnail from the clipboard to a selected catalog.

(Shortcut = Ctrl+V)

See also:
Moving and Copying Thumbnails between Catalogs 



Riffle Feature

The Riffle feature displays the selected catalog's thumbnails one at a time in the lower right 
corner of the main window. The Riffle control is found in the lower right corner of the catalog. 
The blue arrows indicate either the forward or reverse riffle direction.

Control the Riffle speed and direction by holding down the left mouse button and dragging the 
control bar from the center to the left or right of the Riffle Control.    Kudo will advance through 
the catalog until you release the control or until it reaches either end of the catalog.    

When the mouse button is released or the control bar is returned to the center position, Kudo 
stops near the thumbnail that you choose and displays the surrounding thumbnails.    Your 
reactions may be slower than Kudo's Riffle feature, so when you release the Riffle control, you 
may have to select a thumbnail that is a few frames ahead of the one you wanted.    



Using Drag and Drop with File Manager

You can Open/Create Catalogs and Add/Update file/s and directories by dragging them directly from the 
right side of the File Manager's split screen. (See changing Views in the File Manager Help). Simply click 
and hold the left mouse button on a file name or slection of files and drag and drop on Kudo.



Using Drag and Drop with Applications

You can drag and drop Thumbnails from Kudo into applications which support Drag and Drop  this 
feature. Simply click and hold the left mouse button on the thumbnail and drag it to the application and 
drop. Kudo will then search for the original image and place it into the application.



Open Kudo Web Page

Using this feature will display Kudos Web Page on the Internet. To use this feature you need an Internet 
Browser and a modem or other Internet connection hardware.

To view the web page, under the Help Menu, click on Open Kudo Web Page. To return to Kudo from the 
Kudo Web Page you must exit the internet.



Open Catalogs Web Page

Using this feature will display the Catalogs Web Page on the Internet if one exists. To use this feature you
need an Internet Browser and a modem or other Internet connection hardware.

To view the web page, under the Help Menu, click on Open Catalogs Web Page. If no web page exists 
then a message appears indicating this fact. To return to Kudo from the Catalogs Web Page you must exit
the internet.



Keyboard Short Cuts

File Menu
New Ctrl+N
Open Ctrl+O
Add/Update Ctrl+U
Close Ctrl+W
Print Ctrl+P
Exit Alt+F4

Edit Menu
Cut Thumbnail Ctrl+X
Copy Thumbnail Ctrl+C
Paste Thumbnail Ctrl+V

View Menu
Small Gallery Ctrl+S
Gallery Ctrl+G
List Ctrl+L

Image Menu
Display Original Ctrl+E
Get Info Ctrl+I
Find Ctrl+F
Find All Ctrl+A
Rotate Thumbnail
Flip Thumbnail

Help F1 or Alt+H
Index F1
Using Help
Open Kudo Web Page Alt+K
Open Catalogs Web Page
About



Supported File Formats

Go to the file Kudo.ini for upto date information on import filters.



Kudo and Wild Cards

Kudo lets you use wild cards when using Add/Update to search for files with similar names or file types.

Examples:

*.BMP  - search for all the bmp files.
*.??F  - search for all files with an extension ending in F i.e. GIF TIF etc.
P*.*  - search for all files starting with P regardless of the extension.



Image Resolution

1) Poor Color scans : When scanning catalogs on machines with less than 256 colors, images are 
scanned at the color resolution of the machine. For instance, if you are running in standard VGA mode, 
which is 16-colors, scanning catalogs produces images that are limited to 16 colors. Of course this will 
look fine if all the images are 16-color or less, but will be less than satisfactory if you are trying to scan 
256-color or greater images. Kudo scans its catalogs as 256-color images, so running in video modes at 
or above 256-color, such as 256-color, 32k color or 16 million color will produce accurate, full-color scans.

2) Defects Caused by Bad Video Drivers: Video drivers are written by video manufacturers and there 
are lots of them out there. Because of our indirect reliance on the video driver code, via the Microsoft 
Windows graphics operations that we employ, we have found that software defects in these drivers can 
affect the functioning of Kudo. In particular we have seen two situations so far that have affected Kudo.

--Many 256-color video drivers do not handle the system color palette correctly for the graphics 
operations we use. As a result, the catalog image colors were being corrupted during catalog scans on 
certain video cards, in 8-bit mode. This problem was common enough that Imspace decided to implement
a work-around in the code to alleviate this side effect. The result of this work-around is that there is a 
corruption of the actual screen color palette during catalog scanning on 256-color machines. This shows 
up primarily as a corruption of the thumbnail being displayed in the progress dialog box, and excessive 
redrawing of any open catalogs and other applications that may be visible with 256-color graphics. This 
includes the background desktop wallpaper if it is a 256-color bitmap. This corruption will not be evident 
on machines with greater than 256-colors, and its effect is cosmetic only--the catalogs will scan correctly.

--There are occasional software bugs in video drivers that simply manifest as an application failure in 
Kudo. These are uncommon, and it usually takes a rather obscure combination of video driver and image 
to produce this sort of problem. The readme.txt file lists all the known drivers with observed problems. 
The short term solution to this would be to upgrade the video driver if possible.

3) 24-bit Color is Slow on 8-bit Machines: On a 256-color machine, catalog scanning, image previewing, 
and image copying to the clipboard is unnecessarily slow when dealing with images of color depth greater
than 256-color (such as 32k color or 16 million color). This problem only occurs in this situation. It does 
not occur on machines in color modes greater than 256-color, nor on machines running at 16-color. Also, 
on machines running in 256-color mode, the problem will not occur with images of color depth equal to or 
less than 256-color. This again is due to the internal use of Microsoft Windows video device specific 
operations. These operations must laboriously perform a nearest color search for every pixel of an image 
when running on 256-color machines. The problem IS simply one of speed and causes no corruption of 
catalog scans or previews. It will manifest during catalog scanning as the lengthy appearance of the 
hourglass cursor during the "Reading ..." and "Analyzing ..." operations. It will manifest during image 
previewing and clipboard operations as the lengthy appearance of the hourglass cursor immediately after 
initiating the operation. Unfortunately, mouse input is frozen while caught in this graphics operation, so 
you must just wait until it completes before going on, or canceling, if in a scan. To cancel a scan, you must
wait until the mouse cursor returns to normal for it to correctly activate the cancel button. However, all 
operations will proceed normally if you don't mind waiting.

These design limitations are temporary only--Imspace Systems is currently modifying Kudo' to remedy 
these limitations. In addition to correcting the device dependency limitations, these modifications will 
speed up the normal operation of Kudo as a result of removing our reliance on the built-in Microsoft 
Windows operations. It takes extra software to replace these operations which is the reason that the 
changes were deferred in favor of getting a useful product to market in a shorter time.

 







Rotate Thumbnails

Kodak Photo CD images are always in landscape orientation when you get them from the developer.    
With Kudo you can rotate thumbnail images so that they can be viewed in the correct orientation within a 
catalog.

Select the thumbnail you wish to rotate.

Choose Rotate Thumbnail from the Image menu.

Kudo will rotate the thumbnail in 90 degree increments each time the option is selected.

Rotating the thumbnail does not change the original image in any way.    Only the orientation of the 
thumbnail image in the Kudo catalog is changed.



Flip Thumbnails

When Kodak Photo CDs are made from 35mm slides, the images may be put on your Photo CD 
reversed.    With Kudo you can flip the images so that they can be viewed in the correct orientation within 
a catalog.

The Flip Thumbnail feature is accessed in the same way as the Rotated Thumbnail feature.    Flipping the 
thumbnail does not change the original image in any way.    Only the orientation of the thumbnail image in 
the Kudo catalog is changed.




